Het lijkt erop dat de service Website The Courseware Company niet werkt

Major incident
08-04-2021 06:37 CEST · 28 minutes

Updates

Resolved

De service werkt weer.

08-04-2021 · 07:05 CEST
Issue

Volgens ons controlesysteem reageert deze service niet meer. We zijn het aan het onderzoeken.

08-04-2021 · 06:37 CEST

← Back