Network disruption in our Customer Care Center

Minor incident Courseware
26-09-2022 10:17 CEST · 1 hour, 46 minutes

Updates

Resolved

The disruption is resolved. You can reach us via our Customer Care Center again.

September 26, 2022 · 12:04 CEST
Update

The supplier has found the cause of this disruption and is working on the solution. As soon as we know more about this, we’ll place another update.

September 26, 2022 · 11:47 CEST
Investigating

The supplier of our ticketingsystem has a network disruption at this moment. It is under investigation and as soon as we know more, we’ll inform you as well.

September 26, 2022 · 10:35 CEST

← Back